composerでgoogle apiをインストール

プログラム

phpでgoogle apiを使う為にまず下記コマンドでcomposerでインストールされている項目を最新版にアップデートする。

composer update

そうするとエラーが発生したのですが、下記の項目が重要みたいです。

    - Installation request for laravel/framework ^6.2 -> satisfiable by laravel/framework[6.x-dev, v6.10.0, v6.10.1, v6.11.0, v6.12.0, v6.13.0, v6.13.1, v6.14.0, v6.15.0, v6.15.1, v6.16.0, v6.17.0, v6.17.1, v6.18.0, v6.18.1, v6.18.2, v6.18.3, v6.18.4, v6.18.5, v6.18.6, v6.2.0, v6.3.0, v6.4.0, v6.4.1, v6.5.0, v6.5.1, v6.5.2, v6.6.0, v6.6.1, v6.6.2, v6.7.0, v6.8.0, v6.9.0].
    - Installation request for laravel/ui ^2.0 -> satisfiable by laravel/ui[2.x-dev, v2.0.0, v2.0.1].

composer.jsonからlaravel/uiの項目を削除したらアップデートできました。
下記コマンドでgoogle apiをインストール

composer require google/apiclient:^2.0

無事アップデート完了しました。

vendorフォルダ配下にgoogleのフォルダがインストールされている事を確認して完了